[libcamera-devel] [PATCH 2/5] libcamera: media_device: Add function to get a MediaLink
Jacopo Mondi
jacopo at jmondi.org
Tue Jan 8 14:49:33 CET 2019
Hi Laurent,
On Mon, Jan 07, 2019 at 11:39:43PM +0200, Laurent Pinchart wrote:
> Hello,
>
[snip]
> > > > + */
> > > > +MediaLink *MediaDevice::link(const std::string sourceName, unsigned int
> > > > sourceIdx,
> > > > + const std::string sinkName, unsigned int sinkIdx)
> > > > const
>
> Isn't it dangerous to create a function that allows modifying a link from a
> const MediaDevice ? Should you provide both
>
> MediaLink *MediaDevice::link(...)
> const MediaLink *MediaDevice::link(...) const
>
> ? If you don't want to provide both I think you could go for the former only,
> as I don't think we'll have to deal with const MediaDevice pointers.
The function is declared as:
MediaLink *MediaDevice::link(...) const
and not
const MediaLink *MediaDevice::link(...) const
and indeed the function itself does not change the MediaDevice
instance state. Would you drop the const at end of the declaration?
Thanks
j
>
> > > > +{
> > > > + const MediaEntity *source = getEntityByName(sourceName);
> > > > + if (!source) {
> > > > + LOG(Error) << "Failed to find entity with name: "
> > > > + << sourceName << "\n";
>
> I'd go for LOG(Debug) at most. I think it's a valid use case for a user to
> call this function to get a link without knowing whether it is present in the
> graph. This can be used to test for the availability of a link in a media
> device that supports multiple configurations. Even as a debug message I'm not
> sure how valuable this is. Same for the messages below.
>
> All these comments apply to the other two functions below.
>
> > > > + return nullptr;
> > > > + }
> > > > +
> > > > + const MediaPad *sourcePad = source->getPadByIndex(sourceIdx);
> > > > + if (!sourcePad) {
> > > > + LOG(Error) << "Entity \"" << sourceName << "\" "
> > > > + << "has no pad at index " << sourceIdx << "\n";
> > > > + return nullptr;
> > > > + }
> > > > +
> > > > + const MediaEntity *sink = getEntityByName(sinkName);
> > > > + if (!sink) {
> > > > + LOG(Error) << "Failed to find entity with name: "
> > > > + << sinkName << "\n";
> > > > + return nullptr;
> > > > + }
> > > > +
> > > > + const MediaPad *sinkPad = sink->getPadByIndex(sinkIdx);
> > > > + if (!sinkPad) {
> > > > + LOG(Error) << "Entity \"" << sinkName << "\" "
> > > > + << "has no pad at index " << sinkIdx << "\n";
> > > > + return nullptr;
> > > > + }
> > > > +
> > > > + return link(sourcePad, sinkPad);
> > >
> > > How about just resolving the source and sink MediaEntity's here and then
> > >
> > > return link(source, sourceIdx, sink, sinkIdx);
> > >
> > > This would reduce the code duplication.
> >
> > Ah, right, no need to search for the source and sink pads here.
> > I'll fix.
> >
> > > > +}
> > > > +
> > > > +/**
> > > > + * \brief Return the MediaLink that connects two entities
> > > > + * \param source The source entity
> > > > + * \param sourceIdx The index of the source pad
> > > > + * \param sink The sink entity
> > > > + * \param sinkIdx The index of the sink pad
> > > > + *
> > > > + * Find link that connects the pads at index \a sourceIdx of the source
> > > > + * entity \a source, to the pad at index \a sinkIdx of the sink entity
> > > > \a
> > > > + * sink, if any.
> > > > + *
> > > > + * \sa MediaDevice::link(const std::string sourceName, unsigned int
> > > > sourceIdx, const std::string sinkName, unsigned int sinkIdx) const + *
> > > > \sa MediaDevice::link(const MediaPad *source, const MediaPad *sink)
> > > > const + *
> > > > + * \return The link that connects the two entities, nullptr otherwise
> > > > + */
> > > > +MediaLink *MediaDevice::link(const MediaEntity *source, unsigned int
> > > > sourceIdx,
> > > > + const MediaEntity *sink, unsigned int sinkIdx)
> > > > const
> > > > +{
> > > > +
> > > > + const MediaPad *sourcePad = source->getPadByIndex(sourceIdx);
> > > > + if (!sourcePad) {
> > > > + LOG(Error) << "Entity \"" << source->name() << "\" "
> > > > + << "has no pad at index " << sourceIdx << "\n";
> > > > + return nullptr;
> > > > + }
> > > > +
> > > > + const MediaPad *sinkPad = sink->getPadByIndex(sinkIdx);
> > > > + if (!sinkPad) {
> > > > + LOG(Error) << "Entity \"" << sink->name() << "\" "
> > > > + << "has no pad at index " << sinkIdx << "\n";
> > > > + return nullptr;
> > > > + }
> > > > +
> > > > + return link(sourcePad, sinkPad);
> > > > +}
> > > > +
> > > > +/**
> > > > + * \brief Return the MediaLink that connects two pads
> > > > + * \param source The source pad
> > > > + * \param sink The sink pad
> > > > + *
> > > > + * \sa MediaDevice::link(const std::string sourceName, unsigned int
> > > > sourceIdx, const std::string sinkName, unsigned int sinkIdx) const + *
> > > > \sa MediaDevice::link(const MediaEntity *source, unsigned int
> > > > sourceIdx, const MediaEntity *sink, unsigned int sinkIdx) const
> > > > + *
> > > > + * \return The link that connects the two pads, nullptr otherwise
> > > > + */
> > > > +MediaLink *MediaDevice::link(const MediaPad *source, const MediaPad
> > > > *sink) const
> > > > +{
> > > > + if (!source || !sink)
> > > > + return nullptr;
>
> Can this happen ?
>
> > > > + /*
> > > > + * Now that we have made sure all instances are valid, compare
> > > > + * their ids to find a matching link.
> > > > + */
> > >
> > > I like comments in the code it self. I don't like (but I still write
> > > them my self) comments that are written in this tens, how about.
> > >
> > > Compare pad ids to find the link which connects the source and sink
> > > pads.
> >
> > Ack for this and for the comments style in general.
> >
> > > > + for (MediaLink *link : source->links()) {
> > > > + if (link->sink()->id() != sink->id())
> > > > + continue;
> > > > +
> > > > + if (link->sink()->entity()->id() != sink->entity()->id())
> > > > + continue;
>
> Do you need this check given that the id is unique ? It seems to be only
> needed if you search based on pad index, not when searching on pad id. You
> could thus write
>
> if (link->sink()->id() == sink->id())
> return link;
>
> > > > + return link;
> > > > + }
> > > > +
> > > > + return nullptr;
> > > > +}
> > > > +
> > > > /**
> > > > * \var MediaDevice::objects_
> > > > * \brief Global map of media objects (entities, pads, links) keyed by
> > > > their
>
> --
> Regards,
>
> Laurent Pinchart
>
>
>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <https://lists.libcamera.org/pipermail/libcamera-devel/attachments/20190108/a7ada133/attachment.sig>
More information about the libcamera-devel
mailing list