[libcamera-devel] [PATCH 2/2] libcamera: v4l2_device: Add methods to get/set format

Jacopo Mondi jacopo at jmondi.org
Wed Jan 30 15:37:13 CET 2019


Hi Laurent,

On Wed, Jan 30, 2019 at 01:10:00PM +0200, Laurent Pinchart wrote:
> Hi Jacopo,
>
> Thank you for the patch.
>
> On Mon, Jan 28, 2019 at 04:11:37PM +0100, Jacopo Mondi wrote:
> > Add methods to set and get the image format programmed on a V4L2Device
> > for both the single and multi planar use case.
> >
> > Signed-off-by: Jacopo Mondi <jacopo at jmondi.org>
> > ---
> >  src/libcamera/include/v4l2_device.h |  10 +++
> >  src/libcamera/v4l2_device.cpp       | 128 ++++++++++++++++++++++++++++
> >  2 files changed, 138 insertions(+)
> >
> > diff --git a/src/libcamera/include/v4l2_device.h b/src/libcamera/include/v4l2_device.h
> > index c70959e..fe54220 100644
> > --- a/src/libcamera/include/v4l2_device.h
> > +++ b/src/libcamera/include/v4l2_device.h
> > @@ -86,10 +86,20 @@ public:
> >  	const char *deviceName() const { return caps_.card(); }
> >  	const char *busName() const { return caps_.bus_info(); }
> >
> > +	int format(V4L2DeviceFormat *fmt);
>
> As an exception to the general rule, I'd rename format() to getFormat()
> to follow the V4L2 naming. I won't push hard for this, but I think this
> was the general preference of the team as well.
>

iirc we discussed that and went for this solution. I can re-change it
in case..

> > +	int setFormat(V4L2DeviceFormat *fmt);
>
> How about spelling format in full (here and below) for the function
> parameter ?
>

Ok

> > +
> >  private:
> >  	std::string deviceNode_;
> >  	int fd_;
> >  	V4L2Capability caps_;
> > +	enum v4l2_buf_type bufferType_;
> > +
> > +	int getFormatSingleplane(V4L2DeviceFormat *fmt);
> > +	int setFormatSingleplane(V4L2DeviceFormat *fmt);
> > +
> > +	int getFormatMultiplane(V4L2DeviceFormat *fmt);
> > +	int setFormatMultiplane(V4L2DeviceFormat *fmt);
> >  };
> >
> >  } /* namespace libcamera */
> > diff --git a/src/libcamera/v4l2_device.cpp b/src/libcamera/v4l2_device.cpp
> > index d6143f2..5c415d0 100644
> > --- a/src/libcamera/v4l2_device.cpp
> > +++ b/src/libcamera/v4l2_device.cpp
> > @@ -227,6 +227,15 @@ int V4L2Device::open()
> >  		return -EINVAL;
> >  	}
> >
> > +	if (caps_.isCapture())
> > +		bufferType_ = caps_.isMultiplanar()
> > +			    ? V4L2_BUF_TYPE_VIDEO_CAPTURE_MPLANE
> > +			    : V4L2_BUF_TYPE_VIDEO_CAPTURE;
> > +	else
> > +		bufferType_ = caps_.isMultiplanar()
> > +			    ? V4L2_BUF_TYPE_VIDEO_OUTPUT_MPLANE
> > +			    : V4L2_BUF_TYPE_VIDEO_OUTPUT;
> > +
> >  	return 0;
> >  }
> >
> > @@ -269,4 +278,123 @@ void V4L2Device::close()
> >   * \return The string containing the device location
> >   */
> >
> > +/**
> > + * \brief Retrieve the image format set on the V4L2 device
> > + * \return 0 for success, a negative error code otherwise
>
> s/for/on/
>
> > + */
> > +int V4L2Device::format(V4L2DeviceFormat *fmt)
> > +{
> > +	return caps_.isMultiplanar() ? getFormatMultiplane(fmt) :
> > +				       getFormatSingleplane(fmt);
> > +}
> > +
> > +/**
> > + * \brief Configure an image format on the V4L2 device
> > + * \return 0 for success, a negative error code otherwise
>
> s/for/on/
>
> > + */
> > +int V4L2Device::setFormat(V4L2DeviceFormat *fmt)
> > +{
> > +	return caps_.isMultiplanar() ? setFormatMultiplane(fmt) :
> > +				       setFormatSingleplane(fmt);
> > +}
> > +
> > +int V4L2Device::getFormatSingleplane(V4L2DeviceFormat *fmt)
> > +{
> > +	struct v4l2_format v4l2Fmt;
>
> v4l2Format ? Or maybe just fmt if you rename the function parameter to
> format ?
>

Ok

> You need to initialize v4l2Fmt to 0, that's a requirement of the V4L2
> API. = {}; will suffice.
>

correct.

> > +	struct v4l2_pix_format *pix = &v4l2Fmt.fmt.pix;
> > +	int ret;
> > +
> > +	v4l2Fmt.type = bufferType_;
> > +	ret = ioctl(fd_, VIDIOC_S_FMT, &v4l2Fmt);
>
> Shouldn't this be VIDIOC_G_FMT ? This outlines a missing test case :-)
>

My bad, I'm sorry.
For a test case, how should we make sure we test all possible use
cases (planar/multiplanar, capture/output). The device that runs the
test might not have all of these... Could VIMC or vivid help us here?

> > +	if (ret) {
> > +		ret = -errno;
> > +		LOG(Error) << "Unable to get format: " << strerror(-ret);
> > +		return ret;
> > +	}
> > +
> > +	fmt->width = pix->width;
> > +	fmt->height = pix->height;
> > +	fmt->fourcc = pix->pixelformat;
> > +	fmt->planes = 1;
> > +	fmt->planesFmt[0].bpl = pix->bytesperline;
> > +	fmt->planesFmt[0].size = pix->sizeimage;
> > +
> > +	return 0;
> > +}
> > +
> > +int V4L2Device::setFormatSingleplane(V4L2DeviceFormat *fmt)
> > +{
> > +	struct v4l2_format v4l2Fmt;
> > +	struct v4l2_pix_format *pix = &v4l2Fmt.fmt.pix;
> > +	int ret;
> > +
> > +	v4l2Fmt.type = bufferType_;
> > +	pix->width = fmt->width;
> > +	pix->height = fmt->height;
> > +	pix->pixelformat = fmt->fourcc;
>
> How about bytesperline and sizeimage ?
>

The description here
https://www.kernel.org/doc/html/v4.13/media/uapi/v4l/pixfmt-002.html#c.v4l2_pix_format
quite confused me.

Particularly: "Size in bytes of the buffer to hold a complete image,
set by the driver."

> > +
> > +	ret = ioctl(fd_, VIDIOC_S_FMT, &v4l2Fmt);
> > +	if (ret) {
> > +		ret = -errno;
> > +		LOG(Error) << "Unable to set format: " << strerror(-ret);
> > +		return ret;
> > +	}
> > +
>
> Shouldn't fmt be updated ?
>

Good question, what semantic would we want to assign to this
functions? A setFormat returns an updated format? I here thought to
clearly separate this: to know what is actually set, you have to call
g_fmt again. Honestly, now that I re-think this, I am not convinced
anymore this is the right way, as the V4L2 S_FMT actually returns an
updated format, so it might be worth updating it here before return.

> > +	return 0;
> > +}
> > +
> > +int V4L2Device::getFormatMultiplane(V4L2DeviceFormat *fmt)
>
> The above comments hold for the mplane functions too.
>
> > +{
> > +	struct v4l2_format v4l2Fmt;
> > +	struct v4l2_pix_format_mplane *pix = &v4l2Fmt.fmt.pix_mp;
> > +	int ret;
> > +
> > +	v4l2Fmt.type = bufferType_;
> > +	ret = ioctl(fd_, VIDIOC_G_FMT, &v4l2Fmt);

At least this one is right...

Thanks
  j

> > +	if (ret) {
> > +		ret = -errno;
> > +		LOG(Error) << "Unable to get format: " << strerror(-ret);
> > +		return ret;
> > +	}
> > +
> > +	fmt->width = pix->width;
> > +	fmt->height = pix->height;
> > +	fmt->fourcc = pix->pixelformat;
> > +	fmt->planes = pix->num_planes;
> > +
> > +	for (unsigned int i = 0; i < fmt->planes; ++i) {
> > +		fmt->planesFmt[i].bpl = pix->plane_fmt[i].bytesperline;
> > +		fmt->planesFmt[i].size = pix->plane_fmt[i].sizeimage;
> > +	}
> > +
> > +	return 0;
> > +}
> > +
> > +int V4L2Device::setFormatMultiplane(V4L2DeviceFormat *fmt)
> > +{
> > +	struct v4l2_format v4l2Fmt;
> > +	struct v4l2_pix_format_mplane *pix = &v4l2Fmt.fmt.pix_mp;
> > +	int ret;
> > +
> > +	v4l2Fmt.type = bufferType_;
> > +	pix->width = fmt->width;
> > +	pix->height = fmt->height;
> > +	pix->pixelformat = fmt->fourcc;
> > +	pix->num_planes = fmt->planes;
> > +
> > +	for (unsigned int i = 0; i < pix->num_planes; ++i) {
> > +		pix->plane_fmt[i].bytesperline = fmt->planesFmt[i].bpl;
> > +		pix->plane_fmt[i].sizeimage = fmt->planesFmt[i].size;
> > +	}
> > +
> > +	ret = ioctl(fd_, VIDIOC_S_FMT, &v4l2Fmt);
> > +	if (ret) {
> > +		ret = -errno;
> > +		LOG(Error) << "Unable to set format: " << strerror(-ret);
> > +		return ret;
> > +	}
> > +
> > +	return 0;
> > +}
> > +
> >  } /* namespace libcamera */
>
> --
> Regards,
>
> Laurent Pinchart
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <https://lists.libcamera.org/pipermail/libcamera-devel/attachments/20190130/3de3224e/attachment-0001.sig>


More information about the libcamera-devel mailing list