[libcamera-devel] [PATCH v2 0/2] libcamera: Introduce V4L2Device base class
Jacopo Mondi
jacopo at jmondi.org
Wed Jun 12 15:38:15 CEST 2019
Thanks to Kieran the patch is now split in 2: rename then V4L2Device
introduction.
To address Laurent's request, only V4L2Device is now renamed in V4L2VideoDevice
and V4L2Subdevice stays the same.
A few minor changes in the newly introduced V4L2Device base class to address a
few review comments.
Thanks Kieran for helping in splitting the patch, hopefully it is more easily
reviewable in this state.
Thanks
j
Jacopo Mondi (2):
libcamera: Rename V4L2Device to V4L2VideoDevice
libcamera: Introduce V4L2Device base class
include/libcamera/buffer.h | 2 +-
src/libcamera/include/v4l2_device.h | 166 +--
src/libcamera/include/v4l2_subdevice.h | 6 +-
src/libcamera/include/v4l2_videodevice.h | 183 ++++
src/libcamera/meson.build | 2 +
src/libcamera/pipeline/ipu3/ipu3.cpp | 24 +-
src/libcamera/pipeline/rkisp1/rkisp1.cpp | 6 +-
src/libcamera/pipeline/uvcvideo.cpp | 6 +-
src/libcamera/pipeline/vimc.cpp | 6 +-
src/libcamera/v4l2_device.cpp | 980 +----------------
src/libcamera/v4l2_subdevice.cpp | 68 +-
src/libcamera/v4l2_videodevice.cpp | 991 ++++++++++++++++++
test/meson.build | 2 +-
.../buffer_sharing.cpp | 18 +-
.../capture_async.cpp | 6 +-
.../double_open.cpp | 8 +-
.../formats.cpp | 8 +-
.../meson.build | 8 +-
.../request_buffers.cpp | 6 +-
.../stream_on_off.cpp | 6 +-
.../v4l2_videodevice_test.cpp} | 8 +-
.../v4l2_videodevice_test.h} | 8 +-
22 files changed, 1321 insertions(+), 1197 deletions(-)
create mode 100644 src/libcamera/include/v4l2_videodevice.h
create mode 100644 src/libcamera/v4l2_videodevice.cpp
rename test/{v4l2_device => v4l2_videodevice}/buffer_sharing.cpp (90%)
rename test/{v4l2_device => v4l2_videodevice}/capture_async.cpp (91%)
rename test/{v4l2_device => v4l2_videodevice}/double_open.cpp (75%)
rename test/{v4l2_device => v4l2_videodevice}/formats.cpp (85%)
rename test/{v4l2_device => v4l2_videodevice}/meson.build (74%)
rename test/{v4l2_device => v4l2_videodevice}/request_buffers.cpp (77%)
rename test/{v4l2_device => v4l2_videodevice}/stream_on_off.cpp (78%)
rename test/{v4l2_device/v4l2_device_test.cpp => v4l2_videodevice/v4l2_videodevice_test.cpp} (90%)
rename test/{v4l2_device/v4l2_device_test.h => v4l2_videodevice/v4l2_videodevice_test.h} (81%)
--
2.21.0
More information about the libcamera-devel
mailing list