[libcamera-devel] [PATCH 1/2] libcamera: ipc: unix: Add a IPC mechanism based on Unix sockets

Niklas Söderlund niklas.soderlund at ragnatech.se
Sun Jun 30 15:55:52 CEST 2019


Hi Laurent,

Thanks for your feedback. As always a special thanks to your comments on 
the documentation!

On 2019-06-28 15:03:26 +0300, Laurent Pinchart wrote:

> > +	int sendData(void *buffer, size_t length, const int32_t *fds, 
> > unsigned int num);
> 
> How about passing the Payload reference to this function ? It would make
> its signature simpler, and the code more readable in my opinion.
> 
> > +
> > +	int recv();
> > +	int recvData(void *buffer, size_t length, int32_t *fds, unsigned int num);
> 
> Same comment here.

I kind of like this interface as the translation from C++ objects is 
handled in send() and receive() and {send,recv}Data() can deal with the 
just transmitting data. I will keep this for v2 while addressing all 
other comments in this review.

-- 
Regards,
Niklas Söderlund


More information about the libcamera-devel mailing list