[libcamera-devel] [PATCH v7] test: gstreamer: Add test for gstreamer single stream

Vedant Paranjape vedantparanjape160201 at gmail.com
Fri Aug 13 08:14:19 CEST 2021


Hi Laurent,
Thanks for the detailed review.

On Fri, Aug 13, 2021 at 5:55 AM Laurent Pinchart <
laurent.pinchart at ideasonboard.com> wrote:

> Hi Vedant,
>
> Thank you for the patch.
>
> On Thu, Aug 12, 2021 at 04:10:30PM +0530, Vedant Paranjape wrote:
> > This patch adds a test to test if single stream using
> > libcamera's gstreamer element works.
> >
> > Signed-off-by: Vedant Paranjape <vedantparanjape160201 at gmail.com>
> > Reviewed-by: Paul Elder <paul.elder at ideasonboard.com>
> > ---
> >  .../gstreamer_single_stream_test.cpp          | 134 ++++++++++++++++++
> >  test/gstreamer/meson.build                    |  19 +++
> >  test/meson.build                              |   1 +
> >  3 files changed, 154 insertions(+)
> >  create mode 100644 test/gstreamer/gstreamer_single_stream_test.cpp
> >  create mode 100644 test/gstreamer/meson.build
> >
> > diff --git a/test/gstreamer/gstreamer_single_stream_test.cpp
> b/test/gstreamer/gstreamer_single_stream_test.cpp
> > new file mode 100644
> > index 00000000..040b1e7e
> > --- /dev/null
> > +++ b/test/gstreamer/gstreamer_single_stream_test.cpp
> > @@ -0,0 +1,134 @@
> > +/* SPDX-License-Identifier: GPL-2.0-or-later */
> > +/*
> > + * Copyright (C) 2021, Vedant Paranjape
> > + *
> > + * ipa_interface_test.cpp - Test the IPA interface
> > + */
> > +
> > +#include <iostream>
> > +
> > +#include <libcamera/base/utils.h>
> > +
> > +#include <gst/gst.h>
> > +
> > +#include "test.h"
> > +
> > +using namespace std;
> > +
> > +class GstreamerSingleStreamTest : public Test
> > +{
> > +protected:
> > +     int init() override
> > +     {
> > +             /* Initialize GStreamer */
> > +             GError *err_init = nullptr;
>
> Let's use the libcamera coding style, this should be errInit. Same for
> libcamera_src_.
>
> > +             if (!gst_init_check(nullptr, nullptr, &err_init)) {
> > +                     g_printerr("Could not initialize GStreamer: %s\n",
> > +                                err_init ? err_init->message : "unknown
> error");
> > +                     if (err_init)
> > +                             g_error_free(err_init);
> > +
> > +                     return TestFail;
> > +             }
> > +
> > +             if (!gst_registry_scan_path(gst_registry_get(),
> > +
>  std::string(libcamera::utils::libcameraBuildPath() +
> > +                                                     "src/gstreamer")
> > +                                                 .c_str())) {
>
> Let's use a local variable to make this a bit more readable.
>
>                 std::string path = libcamera::utils::libcameraBuildPath()
>                                  + "src/gstreamer";
>                 if (!gst_registry_scan_path(gst_registry_get(),
> path.c_str()) {
>
> > +                     g_printerr("Failed to add plugin to registry\n");
>
> You need to call gst_deinit() here.
>
> > +                     return TestFail;
> > +             }
>
> This won't work if the libcamerasrc plugin is already installed on the
> system, gst_registry_scan_path() will not add anything in that case. You
> need to remove the plugin first. I've tested the following code:
>
>                 /*
>                  * Remove the system libcamera plugin, if any, and add the
>                  * plugin from the build directory.
>                  */
>                 GstRegistry *registry = gst_registry_get();
>                 GstPlugin *plugin = gst_registry_lookup(registry,
> "libgstlibcamera.so");
>                 if (plugin) {
>                         gst_registry_remove_plugin(registry, plugin);
>                         gst_object_unref(plugin);
>                 }
>
>                 std::string path = libcamera::utils::libcameraBuildPath()
>                                  + "src/gstreamer";
>                 if (!gst_registry_scan_path(registry, path.c_str())) {
>                         g_printerr("Failed to add plugin to registry\n");
>                         gst_deinit();
>                         return TestFail;
>                 }
>
> > +
> > +             /* Create the elements */
> > +             libcamera_src_ = gst_element_factory_make("libcamerasrc",
> "libcamera");
> > +             convert0_ = gst_element_factory_make("videoconvert",
> "convert0");
> > +             sink0_ = gst_element_factory_make("fakevideosink",
> "sink0");
> > +
> > +             /* Create the empty pipeline_ */
> > +             pipeline_ = gst_pipeline_new("test-pipeline");
> > +
> > +             if (!pipeline_ || !convert0_ || !sink0_ ||
> !libcamera_src_) {
> > +                     g_printerr("Not all elements could be created.\n");
>
> cleanup() isn't called if init() fails, so you need to unref pipeline_,
> but also libcamera_src_, convert0_ and sink0_ here. The last three
> elements don't need to be unrefered in cleanup(), because
> gst_bin_add_many() makes the pipeline take ownership of them.
>

I could make all those pointers g_autoptr, right ?

gst_deinit() is also needed here.
>
> > +                     return TestFail;
> > +             }
> > +
> > +             return TestPass;
> > +     }
> > +
> > +     void cleanup() override
> > +     {
> > +             gst_object_unref(bus_);
> > +             gst_element_set_state(pipeline_, GST_STATE_NULL);
>
> I'd move this call to the run() function, just before the
> /* Parse error message */ comment, as it shouldn't be executed if the
> pipeline isn't playing.
>
> > +             gst_object_unref(pipeline_);
> > +             gst_deinit();
> > +     }
> > +
> > +     int run() override
> > +     {
> > +             /* Build the pipeline */
> > +             gst_bin_add_many(GST_BIN(pipeline_), libcamera_src_,
> convert0_, sink0_, NULL);
> > +             if (gst_element_link_many(libcamera_src_, convert0_,
> sink0_, NULL) != TRUE) {
> > +                     g_printerr("Elements could not be linked.\n");
> > +                     gst_object_unref(pipeline_);
>
> This will cause a double unref, as cleanup() will be called.
>
> > +                     return TestFail;
> > +             }
> > +
> > +             /* Start playing */
> > +             ret_ = gst_element_set_state(pipeline_, GST_STATE_PLAYING);
>
> This can be a local variable.
>
> > +             if (ret_ == GST_STATE_CHANGE_FAILURE) {
> > +                     g_printerr("Unable to set the pipeline to the
> playing state.\n");
> > +                     gst_object_unref(pipeline_);
>
> Same here, double unref.
>
> > +                     return TestFail;
> > +             }
> > +
> > +             /* Wait until error or EOS or timeout after 2 seconds */
> > +             GstClockTime timeout = 2000000000;
> > +             bus_ = gst_element_get_bus(pipeline_);
> > +             msg_ = gst_bus_timed_pop_filtered(bus_, timeout,
>
> Both bus and msg can be local variables. Otherwise, for bus_, you'd have
> to initialize it to nullptr, or cleanup() will crash if one of the above
> two conditions is false.
>
> > +
>  GstMessageType((uint)GST_MESSAGE_ERROR | (uint)GST_MESSAGE_EOS));
> > +
> > +             /* Parse error message */
> > +             if (msg_ == NULL)
> > +                     return TestPass;
> > +
> > +             switch (GST_MESSAGE_TYPE(msg_)) {
> > +             case GST_MESSAGE_ERROR:
> > +                     gstreamer_print_error(msg_);
> > +                     return TestFail;
> > +                     break;
> > +             case GST_MESSAGE_EOS:
> > +                     g_print("End-Of-Stream reached.\n");
> > +                     return TestFail;
> > +                     break;
> > +             default:
> > +                     g_printerr("Unexpected message received.\n");
> > +                     return TestFail;
> > +                     break;
> > +             }
>
> A blank line would be nice here.
>
> > +             gst_message_unref(msg_);
>
> This will never be called, as all the cases above return. Furthermore,
> msg_ is leaked in all those cases. I'd remove the return statements, and
> turn the next line into
>
>                 return TestFail;
>
> > +
> > +             return TestPass;
> > +     }
> > +
> > +private:
> > +     GstElement *pipeline_, *libcamera_src_, *convert0_, *sink0_;
>
> One variable per line please:
>
>         GstElement *pipeline_;
>         GstElement *libcamera_src_;
>         GstElement *convert0_;
>         GstElement *sink0_;
>
> > +     GstBus *bus_;
> > +     GstMessage *msg_;
> > +     GstStateChangeReturn ret_;
> > +
> > +     void gstreamer_print_error(GstMessage *msg)
> > +     {
> > +             GError *err;
> > +             gchar *debug_info;
> > +
> > +             gst_message_parse_error(msg, &err, &debug_info);
> > +             g_printerr("Error received from element %s: %s\n",
> > +                        GST_OBJECT_NAME(msg->src), err->message);
> > +             g_printerr("Debugging information: %s\n",
> > +                        debug_info ? debug_info : "none");
> > +             g_clear_error(&err);
> > +             g_free(debug_info);
> > +     }
>
> We usually put functions before variables.
>
> > +};
> > +
> > +TEST_REGISTER(GstreamerSingleStreamTest)
> > diff --git a/test/gstreamer/meson.build b/test/gstreamer/meson.build
> > new file mode 100644
> > index 00000000..b99aa0da
> > --- /dev/null
> > +++ b/test/gstreamer/meson.build
> > @@ -0,0 +1,19 @@
> > +# SPDX-License-Identifier: CC0-1.0
> > +
> > +if not gst_enabled
> > +    subdir_done()
> > +endif
> > +
> > +gstreamer_tests = [
> > +    ['single_stream_test',   'gstreamer_single_stream_test.cpp'],
> > +]
> > +gstreamer_dep = dependency('gstreamer-1.0', required: true)
> > +
> > +foreach t : gstreamer_tests
> > +    exe = executable(t[0], t[1],
> > +                     dependencies : [libcamera_private, gstreamer_dep],
> > +                     link_with : test_libraries,
> > +                     include_directories : test_includes_internal)
> > +
> > +    test(t[0], exe, suite : 'gstreamer', is_parallel : false)
> > +endforeach
> > diff --git a/test/meson.build b/test/meson.build
> > index 3bceb5df..d0466f17 100644
> > --- a/test/meson.build
> > +++ b/test/meson.build
> > @@ -11,6 +11,7 @@ subdir('libtest')
> >
> >  subdir('camera')
> >  subdir('controls')
> > +subdir('gstreamer')
> >  subdir('ipa')
> >  subdir('ipc')
> >  subdir('log')
>
> --
> Regards,
>
> Laurent Pinchart
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.libcamera.org/pipermail/libcamera-devel/attachments/20210813/badf7cd5/attachment-0001.htm>


More information about the libcamera-devel mailing list