[libcamera-devel] [PATCH v1] test: gstreamer: Fix the destructor of GstreamerTest base class

Nicolas Dufresne nicolas at ndufresne.ca
Wed Sep 8 15:42:24 CEST 2021


Le mercredi 08 septembre 2021 à 17:34 +0530, Vedant Paranjape a écrit :
> The destructor tried to check if pipeline_ is a parent of libcameraSrc_.
> This was needed to be checked as if it is, cleanup of libcameraSrc_
> would be handled by pipeline itself.
> 
> Since, the destructor can be called anytime, even when pipeline_ hasn't
> been created, the use of pipeline_ to check if libcameraSrc_ has an
> ancestor as pipeline_ caused a segmentation fault.

This fix i correct since you do call gst_object_ref_sink() after creating the
libcamerasrc element. Element are created with a floating ref and this floating
ref is taken by gst_bin_add() normally, unless you have called ref_sink(). So
for the correctness:

Reviewed-by: Nicolas Dufresne <nicolas.dufresne at collabora.com>

Though, I still believe the implementation is messy and error prone. I would
rather drop the creation of pipeline_ and libcameraSrc_ in the base class, and
use gst_parse_launch() in the tests themself. This would be much more readable,
faster to implement, and less error prone.

> 
> Fixes: f58768092277 ("test: gstreamer: Fix the destructor of GstreamerTest base class")
> Signed-off-by: Vedant Paranjape <vedantparanjape160201 at gmail.com>
> ---
>  test/gstreamer/gstreamer_test.cpp | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
> 
> diff --git a/test/gstreamer/gstreamer_test.cpp b/test/gstreamer/gstreamer_test.cpp
> index dbdcaec0b111..46fa5abaea75 100644
> --- a/test/gstreamer/gstreamer_test.cpp
> +++ b/test/gstreamer/gstreamer_test.cpp
> @@ -69,12 +69,10 @@ GstreamerTest::GstreamerTest()
>  
>  GstreamerTest::~GstreamerTest()
>  {
> -	if (libcameraSrc_ &&
> -	    !gst_object_has_as_ancestor(GST_OBJECT(libcameraSrc_),
> -					GST_OBJECT(pipeline_)))
> -		gst_object_unref(libcameraSrc_);
>  	if (pipeline_)
>  		gst_object_unref(pipeline_);
> +	if (libcameraSrc_)
> +		gst_object_unref(libcameraSrc_);
>  
>  	gst_deinit();
>  }




More information about the libcamera-devel mailing list