[libcamera-devel] [PATCH v8 2/4] cam: event_loop: Rename addEvent to addFDEvent
Eric Curtin
ecurtin at redhat.com
Thu May 5 17:18:49 CEST 2022
Since we now have two types of events addFDEvent and addTimerEvent.
Signed-off-by: Eric Curtin <ecurtin at redhat.com>
---
src/cam/drm.cpp | 4 ++--
src/cam/event_loop.cpp | 4 ++--
src/cam/event_loop.h | 4 ++--
3 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/src/cam/drm.cpp b/src/cam/drm.cpp
index 46e34eb5..421cd61a 100644
--- a/src/cam/drm.cpp
+++ b/src/cam/drm.cpp
@@ -432,8 +432,8 @@ int Device::init()
if (ret < 0)
return ret;
- EventLoop::instance()->addEvent(fd_, EventLoop::Read,
- std::bind(&Device::drmEvent, this));
+ EventLoop::instance()->addFDEvent(fd_, EventLoop::Read,
+ std::bind(&Device::drmEvent, this));
return 0;
}
diff --git a/src/cam/event_loop.cpp b/src/cam/event_loop.cpp
index 181c971c..0c2176c7 100644
--- a/src/cam/event_loop.cpp
+++ b/src/cam/event_loop.cpp
@@ -64,8 +64,8 @@ void EventLoop::callLater(const std::function<void()> &func)
event_base_once(base_, -1, EV_TIMEOUT, dispatchCallback, this, nullptr);
}
-void EventLoop::addEvent(int fd, EventType type,
- const std::function<void()> &callback)
+void EventLoop::addFDEvent(int fd, EventType type,
+ const std::function<void()> &callback)
{
std::unique_ptr<Event> event = std::make_unique<Event>(callback);
short events = (type & Read ? EV_READ : 0)
diff --git a/src/cam/event_loop.h b/src/cam/event_loop.h
index 89215dce..d921cd8f 100644
--- a/src/cam/event_loop.h
+++ b/src/cam/event_loop.h
@@ -36,8 +36,8 @@ public:
void callLater(const std::function<void()> &func);
- void addEvent(int fd, EventType type,
- const std::function<void()> &handler);
+ void addFDEvent(int fd, EventType type,
+ const std::function<void()> &handler);
void addTimerEvent(const std::chrono::milliseconds d,
const std::function<void()> &handler);
--
2.35.1
More information about the libcamera-devel
mailing list