[libcamera-devel] [PATCH] libcamera: camera_manager: Rename parameter to get()

Laurent Pinchart laurent.pinchart at ideasonboard.com
Thu Oct 6 21:55:23 CEST 2022


The CameraManager::get() function takes a string containing the ID of
the requested camera. This is correctly documented and implemented in
the .cpp file, but the header file names the parameter 'name' instead of
'id'. Fix it.

Signed-off-by: Laurent Pinchart <laurent.pinchart at ideasonboard.com>
---
 include/libcamera/camera_manager.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/libcamera/camera_manager.h b/include/libcamera/camera_manager.h
index 7647c2a1c43c..4b1fb7568e83 100644
--- a/include/libcamera/camera_manager.h
+++ b/include/libcamera/camera_manager.h
@@ -31,7 +31,7 @@ public:
 	void stop();
 
 	std::vector<std::shared_ptr<Camera>> cameras() const;
-	std::shared_ptr<Camera> get(const std::string &name);
+	std::shared_ptr<Camera> get(const std::string &id);
 	std::shared_ptr<Camera> get(dev_t devnum);
 
 	void addCamera(std::shared_ptr<Camera> camera,
-- 
Regards,

Laurent Pinchart



More information about the libcamera-devel mailing list