[libcamera-devel] [PATCH v1] qcam: Remove redundant check
Barnabás Pőcze
pobrn at protonmail.com
Wed May 3 14:37:49 CEST 2023
I am now thinking that maybe the subject should be changed from
qcam:
to
apps: qcam:
I checked the output of `git log src/apps/qcam` but there was not a lot to go by.
Should I resend? Or could someone change it if the second version is preferable
when applying?
2023. május 2., kedd 19:55 keltezéssel, Barnabás Pőcze <pobrn at protonmail.com> írta:
> The switch statement checks `roles.size()` with cases for 1 and 2,
> so in the `default` branch, `role.size() > 2`, i.e. it is always
> different from 1, so the check is unnecessary.
>
> Signed-off-by: Barnabás Pőcze <pobrn at protonmail.com>
> ---
> src/apps/qcam/main_window.cpp | 7 ++-----
> 1 file changed, 2 insertions(+), 5 deletions(-)
>
> diff --git a/src/apps/qcam/main_window.cpp b/src/apps/qcam/main_window.cpp
> index fb2db4aa..680668df 100644
> --- a/src/apps/qcam/main_window.cpp
> +++ b/src/apps/qcam/main_window.cpp
> @@ -381,11 +381,8 @@ int MainWindow::startCapture()
> }
> break;
> default:
> - if (roles.size() != 1) {
> - qWarning() << "Unsupported stream configuration";
> - return -EINVAL;
> - }
> - break;
> + qWarning() << "Unsupported stream configuration";
> + return -EINVAL;
> }
>
> /* Configure the camera. */
> --
> 2.40.1
More information about the libcamera-devel
mailing list