[libcamera-devel] [PATCH v2 1/4] libcamera: converter: a few fixes to ConverterFactoryBase documentation
Andrey Konovalov
andrey.konovalov at linaro.org
Wed Sep 20 17:19:18 CEST 2023
Signed-off-by: Andrey Konovalov <andrey.konovalov at linaro.org>
---
src/libcamera/converter.cpp | 17 ++++++++++-------
1 file changed, 10 insertions(+), 7 deletions(-)
diff --git a/src/libcamera/converter.cpp b/src/libcamera/converter.cpp
index fa0f1ec8..466f8421 100644
--- a/src/libcamera/converter.cpp
+++ b/src/libcamera/converter.cpp
@@ -199,16 +199,18 @@ ConverterFactoryBase::ConverterFactoryBase(const std::string name, std::initiali
/**
* \fn ConverterFactoryBase::compatibles()
- * \return The names compatibles
+ * \return The compatibles
*/
/**
- * \brief Create an instance of the converter corresponding to a named factory
- * \param[in] media Name of the factory
+ * \brief Create an instance of the converter corresponding to the media device
+ * \param[in] media the media device to create the converter for
*
* \return A unique pointer to a new instance of the converter subclass
- * corresponding to the named factory or one of its alias. Otherwise a null
- * pointer if no such factory exists
+ * corresponding to the media device. The converter is created by the factory
+ * the name or the alias of which equals to the media device driver name.
+ * If the media device driver name doesn't match anything a null pointer is
+ * returned.
*/
std::unique_ptr<Converter> ConverterFactoryBase::create(MediaDevice *media)
{
@@ -236,10 +238,11 @@ std::unique_ptr<Converter> ConverterFactoryBase::create(MediaDevice *media)
}
/**
- * \brief Add a converter class to the registry
+ * \brief Add a converter factory to the registry
* \param[in] factory Factory to use to construct the converter class
*
- * The caller is responsible to guarantee the uniqueness of the converter name.
+ * The caller is responsible to guarantee the uniqueness of the converter
+ * factory name.
*/
void ConverterFactoryBase::registerType(ConverterFactoryBase *factory)
{
--
2.34.1
More information about the libcamera-devel
mailing list