[PATCH v4 0/4] libcamera: converter: Replace usage of stream index by Stream pointer
Umang Jain
umang.jain at ideasonboard.com
Tue Jun 25 08:27:48 CEST 2024
Hello,
The v3 of the series was tested by Andrei for SoftISP (and myself as well)
git-pw didn't collect the T-b tag (probably because it was sent against
the cover letter) so for records..
Tested-by: Andrei Konovalov <andrey.konovalov.ynk at gmail.com> # sm8250 RB5
On 24/06/24 7:18 pm, Umang Jain wrote:
> The v4l2_converter_m2m and simple pipeline handler are adapt to
> use the new interface. This work roped in software ISP as well,
> which also seems to use indexes (although it doesn't implement converter
> interface) because of a common conversionQueue_ queue used for
> converter_ and swIsp_.
>
> Patch 1/4 and 2/4 drop redundant validation of outputs std::map<>.
>
> Patch 3/4 renames private class V4L2M2MConverter::Stream to
> V4L2M2Mconverter::V4L2M2MStream
>
> Patch 4/4 replaces the stream index usage from converter interface and
> soft isp.
>
> ---
> Tested with mxc-isi running software isp on i.MX8MP platform
> ---
>
> changes in v4:
> - Emplace V4L2M2MStream stream only after configure() succeeds.
> (trivial shuffle of ordering of the call).
> - Collect R-b tags
>
> Changes in v3:
> - Fix issue while running soft-isp
> - Fix missing Doxygen changes
>
> changes in v2:
> - Split out patches 1/4 and 2/4 to tackle validation/sanity check
> - Rename V4L2M2MConverter::Stream to V4L2M2Mconverter::V4L2M2MStream
>
> Umang Jain (4):
> converter: converter_v4l2_m2m: Rectify streams sanity check
> libcamera: software_isp: Drop unnecessary sanity check
> converter: converter_v4l2_m2m: Rename private Stream class
> libcamera: converter: Replace usage of stream index by Stream pointer
>
> include/libcamera/internal/converter.h | 5 +-
> .../internal/converter/converter_v4l2_m2m.h | 13 +--
> .../internal/software_isp/software_isp.h | 5 +-
> src/libcamera/converter.cpp | 6 +-
> .../converter/converter_v4l2_m2m.cpp | 79 ++++++++++---------
> src/libcamera/pipeline/simple/simple.cpp | 14 ++--
> src/libcamera/software_isp/software_isp.cpp | 26 +++---
> 7 files changed, 73 insertions(+), 75 deletions(-)
>
More information about the libcamera-devel
mailing list